import Foundation
let pattern = #"\d+(?=(\/)|(.html))"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"""
http://forums.scamadviser.com/site-feedback-issues-feature-requests/20/
https://forums.questionablecontent.net/index.php/board,1.50.html
https://forums.comodo.com/how-can-i-help-comodo-please-we-need-you-b39.30/
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)