const regex = /(.*?)(\d+)((\/)|(.html))/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(.*?)(\\d+)((\\\/)|(.html))', 'g')
const str = `http://forums.scamadviser.com/site-feedback-issues-feature-requests/20/
https://forums.questionablecontent.net/index.php/board,1.50.html
https://forums.comodo.com/how-can-i-help-comodo-please-we-need-you-b39.30/`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}