import re
regex = re.compile(r"(.*?)(\d+)((\/)|(.html))")
test_str = ("http://forums.scamadviser.com/site-feedback-issues-feature-requests/20/\n\n\n"
"https://forums.questionablecontent.net/index.php/board,1.50.html\n\n\n"
"https://forums.comodo.com/how-can-i-help-comodo-please-we-need-you-b39.30/")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")