// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(.*?)(\d+)((\/)|(.html))").unwrap();
let string = "http://forums.scamadviser.com/site-feedback-issues-feature-requests/20/
https://forums.questionablecontent.net/index.php/board,1.50.html
https://forums.comodo.com/how-can-i-help-comodo-please-we-need-you-b39.30/";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}