import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(<td.*?>)([0-3]?[0-9])\\/([0-3]?[0-9])\\/((?:[0-9]{2})?[0-9]{2})(.*?<\\/td>)";
final String string = "<table>\n"
+ "<tr>\n"
+ "<td class=\"test\">9/2/2021 10:59:15 AM</td>\n"
+ "</tr>\n\n"
+ "<tr>\n"
+ "<td class=\"test\">12/15/2015 12:10:45 PM</td>\n"
+ "</tr>\n\n"
+ "<tr>\n"
+ "<td class=\"test\">10/10/2012 5:00:10 AM</td>\n"
+ "</tr>\n"
+ "</table>\n";
final String subst = "$1$2.$3.$4$5";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}