// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)(<td.*?>)([0-3]?[0-9])\/([0-3]?[0-9])\/((?:[0-9]{2})?[0-9]{2})(.*?<\/td>)").unwrap();
let string = "<table>
<tr>
<td class=\"test\">9/2/2021 10:59:15 AM</td>
</tr>
<tr>
<td class=\"test\">12/15/2015 12:10:45 PM</td>
</tr>
<tr>
<td class=\"test\">10/10/2012 5:00:10 AM</td>
</tr>
</table>
";
let substitution = "$1$2.$3.$4$5";
// result will be a String with the substituted value
let result = regex.replace_all(string, substitution);
println!("{}", result);
}