re = /(<td.*?>)([0-3]?[0-9])\/([0-3]?[0-9])\/((?:[0-9]{2})?[0-9]{2})(.*?<\/td>)/m
str = '<table>
<tr>
<td class="test">9/2/2021 10:59:15 AM</td>
</tr>
<tr>
<td class="test">12/15/2015 12:10:45 PM</td>
</tr>
<tr>
<td class="test">10/10/2012 5:00:10 AM</td>
</tr>
</table>
'
subst = '$1$2.$3.$4$5'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result