#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)\d{11}\b"
Local $sString = "00000000000 00000000001 00000000002 00000000003 00000000010 00000000011 00000000012 00000000014 00000000020 00000000021 00000000022 00000000024 00000000030 00000000031 00000000032 00000000034 00000000100 00000000101 00000000110 00000000111 00000000120 00000000121"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")