import re
regex = re.compile(r"\d{11}\b", flags=re.MULTILINE)
test_str = "00000000000 00000000001 00000000002 00000000003 00000000010 00000000011 00000000012 00000000014 00000000020 00000000021 00000000022 00000000024 00000000030 00000000031 00000000032 00000000034 00000000100 00000000101 00000000110 00000000111 00000000120 00000000121"
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")