import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?<= )[^:]+";
final String string = " open: boolean,\n"
+ " onDidDismiss: () => void,\n"
+ " message: string,\n"
+ " showAddReceiptModal: boolean,\n"
+ " showModal: (value: (((prevState: boolean) => boolean) | boolean)) => void,\n"
+ " vehicleTabRef: React.MutableRefObject<null>,\n"
+ " onReceiptSubmit: (data) => void,\n"
+ " vehicle: any,\n"
+ " showModal1: boolean,\n"
+ " showModal2: (value: (((prevState: boolean) => boolean) | boolean)) => void,\n"
+ " selectedReceipt: { __typename: \"Receipt\" | undefined; id: string | undefined; purchaseDate: string | undefined; sellerName: string | undefined; sellerAddress: string | undefined; sellerCity: string | undefined; sellerState: string | undefined; sellerZipCode: string | undefined; totalAmount: number | undefined; gallonsPurchased: number | undefined; image?: string | null | undefined | undefined; userID?: string | null | undefined | undefined; vehicleID: string | undefined; vehicle?: Vehicle | null | undefined | undefined; taxRefund?: number | null | undefined | undefined; createdAt: string | undefined; updatedAt: string | undefined },\n"
+ " onClick: () => void,\n"
+ " onClick1: () => void,\n"
+ " dataEditing: boolean,\n"
+ " toastMessage: (val) => void,\n"
+ " editing: (bool) => void,\n"
+ " showToast: (bool) => void,\n"
+ " showModal3: boolean,\n"
+ " showModal4: (bool) => void,\n"
+ " dateFilter: { startDate: string; endDate: string },";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}