const regex = /(?<= )[^:]+/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(?<= )[^:]+', 'gm')
const str = ` open: boolean,
onDidDismiss: () => void,
message: string,
showAddReceiptModal: boolean,
showModal: (value: (((prevState: boolean) => boolean) | boolean)) => void,
vehicleTabRef: React.MutableRefObject<null>,
onReceiptSubmit: (data) => void,
vehicle: any,
showModal1: boolean,
showModal2: (value: (((prevState: boolean) => boolean) | boolean)) => void,
selectedReceipt: { __typename: "Receipt" | undefined; id: string | undefined; purchaseDate: string | undefined; sellerName: string | undefined; sellerAddress: string | undefined; sellerCity: string | undefined; sellerState: string | undefined; sellerZipCode: string | undefined; totalAmount: number | undefined; gallonsPurchased: number | undefined; image?: string | null | undefined | undefined; userID?: string | null | undefined | undefined; vehicleID: string | undefined; vehicle?: Vehicle | null | undefined | undefined; taxRefund?: number | null | undefined | undefined; createdAt: string | undefined; updatedAt: string | undefined },
onClick: () => void,
onClick1: () => void,
dataEditing: boolean,
toastMessage: (val) => void,
editing: (bool) => void,
showToast: (bool) => void,
showModal3: boolean,
showModal4: (bool) => void,
dateFilter: { startDate: string; endDate: string },`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}