import re
regex = re.compile(r"(?<= )[^:]+", flags=re.MULTILINE)
test_str = (" open: boolean,\n"
" onDidDismiss: () => void,\n"
" message: string,\n"
" showAddReceiptModal: boolean,\n"
" showModal: (value: (((prevState: boolean) => boolean) | boolean)) => void,\n"
" vehicleTabRef: React.MutableRefObject<null>,\n"
" onReceiptSubmit: (data) => void,\n"
" vehicle: any,\n"
" showModal1: boolean,\n"
" showModal2: (value: (((prevState: boolean) => boolean) | boolean)) => void,\n"
" selectedReceipt: { __typename: \"Receipt\" | undefined; id: string | undefined; purchaseDate: string | undefined; sellerName: string | undefined; sellerAddress: string | undefined; sellerCity: string | undefined; sellerState: string | undefined; sellerZipCode: string | undefined; totalAmount: number | undefined; gallonsPurchased: number | undefined; image?: string | null | undefined | undefined; userID?: string | null | undefined | undefined; vehicleID: string | undefined; vehicle?: Vehicle | null | undefined | undefined; taxRefund?: number | null | undefined | undefined; createdAt: string | undefined; updatedAt: string | undefined },\n"
" onClick: () => void,\n"
" onClick1: () => void,\n"
" dataEditing: boolean,\n"
" toastMessage: (val) => void,\n"
" editing: (bool) => void,\n"
" showToast: (bool) => void,\n"
" showModal3: boolean,\n"
" showModal4: (bool) => void,\n"
" dateFilter: { startDate: string; endDate: string },")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")