#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^ *[0-9][0-9]* *2[0-9-]* *[0-9][0-9]:[0-9][0-9] *"
Local $sString = "Archive: test.zip" & @CRLF & _
" Length Date Time Name" & @CRLF & _
"--------- ---------- ----- ----" & @CRLF & _
" 9 2017-08-24 13:45 1.txt" & @CRLF & _
" 9 2017-08-24 13:45 2.txt" & @CRLF & _
"--------- -------" & @CRLF & _
" 18 2 files" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")