import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^ *[0-9][0-9]* *2[0-9-]* *[0-9][0-9]:[0-9][0-9] *";
final String string = "Archive: test.zip\n"
+ " Length Date Time Name\n"
+ "--------- ---------- ----- ----\n"
+ " 9 2017-08-24 13:45 1.txt\n"
+ " 9 2017-08-24 13:45 2.txt\n"
+ "--------- -------\n"
+ " 18 2 files\n";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}