$re = '/^ *[0-9][0-9]* *2[0-9-]* *[0-9][0-9]:[0-9][0-9] */m';
$str = 'Archive: test.zip
Length Date Time Name
--------- ---------- ----- ----
9 2017-08-24 13:45 1.txt
9 2017-08-24 13:45 2.txt
--------- -------
18 2 files
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);