package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m).*\s(\S+)\:(.+)`)
var str = `Aaaa: ловыа ва лывоа Bbb.bb: sdfkjfsd lksdf Cccc: kjlsdfl lsd`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}