re = /.*\s(\S+)\:(.+)/m
str = 'Aaaa: ловыа ва лывоа Bbb.bb: sdfkjfsd lksdf Cccc: kjlsdfl lsd'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end