package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)(.+?) (.+? .+?) (.+?), (.+)`)
var str = `Анальгин обычный капсулы 300 мг, 20 шт.`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}