re = /(.+?) (.+? .+?) (.+?), (.+)/m
str = 'Анальгин обычный капсулы 300 мг, 20 шт.'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end