$re = '/(.+?) (.+? .+?) (.+?), (.+)/m';
$str = 'Анальгин обычный капсулы 300 мг, 20 шт.';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);