$re = '/[^\[](very sad)[^\]]/m';
$str = 'This is very sad and this is [very sad] and [test;very sad]';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);