re = /[^\[](very sad)[^\]]/m
str = 'This is very sad and this is [very sad] and [test;very sad]'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end