#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "<Compile Include=".*Document\\.*\r*\n*.*<Link>.*\r*\n*.*<\/Compile>(?!<Compile Include)"
Local $sString = " <Compile Include="..\..\Document\Source\CommonAssemblyInfo.cs">" & @CRLF & _
" <Link>CommonAssemblyInfo.cs</Link>" & @CRLF & _
" </Compile>" & @CRLF & _
" <Compile Include="..\..\Reports\ReportsCore\Rendering\Components\InteractiveEventIDs.cs">" & @CRLF & _
" <Link>Rendering\InteractiveEventIDs.cs</Link>" & @CRLF & _
" </Compile>" & @CRLF & _
" <Compile Include="..\..\SL\CommonFiles\SafeGraphics.cs">" & @CRLF & _
" <Link>SafeGraphics.cs</Link>" & @CRLF & _
" </Compile>" & @CRLF & _
" <Compile Include="..\..\VersionInfo.cs">" & @CRLF & _
" <Link>VersionInfo.cs</Link>" & @CRLF & _
" </Compile>"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")