const regex = /<Compile Include=".*Document\\.*\r*\n*.*<Link>.*\r*\n*.*<\/Compile>(?!<Compile Include)/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('<Compile Include=".*Document\\\\.*\\r*\\n*.*<Link>.*\\r*\\n*.*<\\\/Compile>(?!<Compile Include)', 'g')
const str = ` <Compile Include="..\\..\\Document\\Source\\CommonAssemblyInfo.cs">
<Link>CommonAssemblyInfo.cs</Link>
</Compile>
<Compile Include="..\\..\\Reports\\ReportsCore\\Rendering\\Components\\InteractiveEventIDs.cs">
<Link>Rendering\\InteractiveEventIDs.cs</Link>
</Compile>
<Compile Include="..\\..\\SL\\CommonFiles\\SafeGraphics.cs">
<Link>SafeGraphics.cs</Link>
</Compile>
<Compile Include="..\\..\\VersionInfo.cs">
<Link>VersionInfo.cs</Link>
</Compile>`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}