import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "<Compile Include=\".*Document\\\\.*\\r*\\n*.*<Link>.*\\r*\\n*.*<\\/Compile>(?!<Compile Include)";
final String string = " <Compile Include=\"..\\..\\Document\\Source\\CommonAssemblyInfo.cs\">\n"
+ " <Link>CommonAssemblyInfo.cs</Link>\n"
+ " </Compile>\n"
+ " <Compile Include=\"..\\..\\Reports\\ReportsCore\\Rendering\\Components\\InteractiveEventIDs.cs\">\n"
+ " <Link>Rendering\\InteractiveEventIDs.cs</Link>\n"
+ " </Compile>\n"
+ " <Compile Include=\"..\\..\\SL\\CommonFiles\\SafeGraphics.cs\">\n"
+ " <Link>SafeGraphics.cs</Link>\n"
+ " </Compile>\n"
+ " <Compile Include=\"..\\..\\VersionInfo.cs\">\n"
+ " <Link>VersionInfo.cs</Link>\n"
+ " </Compile>";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}