#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?is)(?:(?<=^)|(?<=\n{2}))PASS.+?(?!FAIL).+?CLPM_FPGA_(\d{2})"
Local $sString = "PASS: PLL Lock signal state at reset is 0." & @CRLF & _
"PASS: PLL Lock signal state is 1." & @CRLF & _
"PASS: PLL Locked within expected time: 5000000 ps." & @CRLF & _
"Requirements verified: CLPM_FPGA_31" & @CRLF & _
"" & @CRLF & _
"PASS: System Clock high period is 8000 ps." & @CRLF & _
"FAIL: System Clock low period is 8000 ps." & @CRLF & _
"PASS: System Clock period is 16000 ps." & @CRLF & _
"Requirements verified: CLPM_FPGA_32" & @CRLF & _
"" & @CRLF & _
"PASS: System Clock to IFC delay is 10 ps." & @CRLF & _
"Requirements verified: CLPM_FPGA_33" & @CRLF & _
"" & @CRLF & _
"PASS: System Clock to IFC delay is 10 ps." & @CRLF & _
"Requirements verified: CLPM_FPGA_34" & @CRLF & _
"" & @CRLF & _
"FAIL: System Clock low period is 8000 ps." & @CRLF & _
"PASS: System Clock high period is 8000 ps." & @CRLF & _
"PASS: System Clock period is 16000 ps." & @CRLF & _
"Requirements verified: CLPM_FPGA_35" & @CRLF & _
"" & @CRLF & _
"PASS: System Clock high period is 8000 ps." & @CRLF & _
"PASS: System Clock period is 16000 ps." & @CRLF & _
"FAIL: System Clock low period is 8000 ps." & @CRLF & _
"Requirements verified: CLPM_FPGA_36" & @CRLF & _
"" & @CRLF & _
"FAIL: System Clock low period is 8000 ps." & @CRLF & _
"Requirements verified: CLPM_FPGA_37" & @CRLF & _
"" & @CRLF & _
"PASS: System Clock to IFC delay is 10 ps." & @CRLF & _
"FAIL: System Clock low period is 8000 ps." & @CRLF & _
"Requirements verified: CLPM_FPGA_39" & @CRLF & _
"" & @CRLF & _
"PASS: System Clock to IFC delay is 10 ps." & @CRLF & _
"Requirements verified: CLPM_FPGA_40"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")