const regex = new RegExp('(?:(?<=^)|(?<=\\n{2}))PASS.+?(?!FAIL).+?CLPM_FPGA_(\\d{2})', 'igs')
const str = `PASS: PLL Lock signal state at reset is 0.
PASS: PLL Lock signal state is 1.
PASS: PLL Locked within expected time: 5000000 ps.
Requirements verified: CLPM_FPGA_31
PASS: System Clock high period is 8000 ps.
FAIL: System Clock low period is 8000 ps.
PASS: System Clock period is 16000 ps.
Requirements verified: CLPM_FPGA_32
PASS: System Clock to IFC delay is 10 ps.
Requirements verified: CLPM_FPGA_33
PASS: System Clock to IFC delay is 10 ps.
Requirements verified: CLPM_FPGA_34
FAIL: System Clock low period is 8000 ps.
PASS: System Clock high period is 8000 ps.
PASS: System Clock period is 16000 ps.
Requirements verified: CLPM_FPGA_35
PASS: System Clock high period is 8000 ps.
PASS: System Clock period is 16000 ps.
FAIL: System Clock low period is 8000 ps.
Requirements verified: CLPM_FPGA_36
FAIL: System Clock low period is 8000 ps.
Requirements verified: CLPM_FPGA_37
PASS: System Clock to IFC delay is 10 ps.
FAIL: System Clock low period is 8000 ps.
Requirements verified: CLPM_FPGA_39
PASS: System Clock to IFC delay is 10 ps.
Requirements verified: CLPM_FPGA_40`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}