package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)\S@[^\s]+\s+(?<SPF_RESULT>[^ ]+)`)
var str = `Oct 25 21:16:05 x.x.x.x Splunk_PIApp_MailLogs_QDC: Info: MID 92041462 SPF: mailfrom identity foo@bar.com SoftFail (v=spf1) `
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}