import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "\\s*(<!--[\\s\\S]+?-->)";
final String string = " <header class=\"afl\">\n"
+ " <div class=\"openClose\">\n"
+ " <div class=\"line line1\"></div>\n"
+ " <div class=\"line line2\"></div>\n"
+ " <div class=\"line line3\"></div>\n"
+ " </div>\n"
+ " <div class=\"ssLogo\">\n"
+ " <div class=\"c1\">\n"
+ " <div class=\"c2\">SS</div>\n"
+ " </div>\n"
+ " </div>\n"
+ " <!-- <script data-xd>mcgu/a-/AAuE7mA5Yb1qpx76aqsJ131_TaqMRgH1jd5nVUYrO9yDGQ=s96-c</script> -->\n"
+ " <!-- <script data-xd>mcgu/a-/AAuE7mA5Yb1qpx76aqsJ131_TaqMRgH1jd5nVUYrO9yDGQ=s96-c</script><script data-xd>mcgu/a-/AAuE7mA5Yb1qpx76aqsJ131_TaqMRgH1jd5nVUYrO9yDGQ=s96-c</script>\n"
+ " <script data-xd>mcgu/a-/AAuE7mA5Yb1qpx76aqsJ131_TaqMRgH1jd5nVUYrO9yDGQ=s96-c</script><script data-xd>mcgu/a-/AAuE7mA5Yb1qpx76aqsJ131_TaqMRgH1jd5nVUYrO9yDGQ=s96-c</script>\n"
+ " <script data-xd>mcgu/a-/AAuE7mA5Yb1qpx76aqsJ131_TaqMRgH1jd5nVUYrO9yDGQ=s96-c</script><script data-xd>mcgu/a-/AAuE7mA5Yb1qpx76aqsJ131_TaqMRgH1jd5nVUYrO9yDGQ=s96-c</script>\n"
+ " <script data-xd>mcgu/a-/AAuE7mA5Yb1qpx76aqsJ131_TaqMRgH1jd5nVUYrO9yDGQ=s96-c</script><script data-xd>mcgu/a-/AAuE7mA5Yb1qpx76aqsJ131_TaqMRgH1jd5nVUYrO9yDGQ=s96-c</script>\n\n"
+ " <script data-xd>mcgu/a-/AAuE7mA5Yb1qpx76aqsJ131_TaqMRgH1jd5nVUYrO9yDGQ=s96-c</script><script data-xd>mcgu/a-/AAuE7mA5Yb1qpx76aqsJ131_TaqMRgH1jd5nVUYrO9yDGQ=s96-c</script>\n\n\n"
+ " tdhuitjhuio5hrtjhtryhtujhtohju -->\n"
+ " <div class=\"ssText\">Social Services</div>\n"
+ " <div class=\"menu\">\n"
+ " <div class=\"userData\">\n"
+ " <div class=\"logo\">\n"
+ " <img class=\"userpicture\" src=\"https://lh3.googleusercontent.com/a-/AAuE7mA5Yb1qpx76aqsJ131_TaqMRgH1jd5nVUYrO9yDGQ=s96-c\" alt=\"MD Real\" />\n"
+ " </div>\n"
+ " </div>\n"
+ " </div>\n"
+ " </header>\n"
+ " <aside class=\"leftSidebar open\" id=\"menu\">\n"
+ " <div class=\"controls\">\n"
+ " <div class=\"openClose\">\n"
+ " <div class=\"line line1\"></div>\n"
+ " <div class=\"line line2\"></div>\n"
+ " <div class=\"line line3\"></div>\n"
+ " </div>\n"
+ " </div>\n"
+ " <!-- <script data-xd>mcgu/a-/AAuE7mA5Yb1qpx76aqsJ131_TaqMRgH1jd5nVUYrO9yDGQ=s96-c</script> -->\n"
+ " <!-- <script data-xd>mcgu/a-/AAuE7mA5Yb1qpx76aqsJ131_TaqMRgH1jd5nVUYrO9yDGQ=s96-c</script><script data-xd>mcgu/a-/AAuE7mA5Yb1qpx76aqsJ131_TaqMRgH1jd5nVUYrO9yDGQ=s96-c</script>\n"
+ " <script data-xd>mcgu/a-/AAuE7mA5Yb1qpx76aqsJ131_TaqMRgH1jd5nVUYrO9yDGQ=s96-c</script><script data-xd>mcgu/a-/AAuE7mA5Yb1qpx76aqsJ131_TaqMRgH1jd5nVUYrO9yDGQ=s96-c</script>\n"
+ " <script data-xd>mcgu/a-/AAuE7mA5Yb1qpx76aqsJ131_TaqMRgH1jd5nVUYrO9yDGQ=s96-c</script><script data-xd>mcgu/a-/AAuE7mA5Yb1qpx76aqsJ131_TaqMRgH1jd5nVUYrO9yDGQ=s96-c</script>\n"
+ " <script data-xd>mcgu/a-/AAuE7mA5Yb1qpx76aqsJ131_TaqMRgH1jd5nVUYrO9yDGQ=s96-c</script><script data-xd>mcgu/a-/AAuE7mA5Yb1qpx76aqsJ131_TaqMRgH1jd5nVUYrO9yDGQ=s96-c</script>\n\n"
+ " <script data-xd>mcgu/a-/AAuE7mA5Yb1qpx76aqsJ131_TaqMRgH1jd5nVUYrO9yDGQ=s96-c</script><script data-xd>mcgu/a-/AAuE7mA5Yb1qpx76aqsJ131_TaqMRgH1jd5nVUYrO9yDGQ=s96-c</script>\n\n\n"
+ " tdhuitjhuio5hrtjhtryhtujhtohju -->\n"
+ " <div id=\"system\" class=\"system\" data-textarea=\"Social Services\">\n"
+ " <a href=\"\" data-content=\"Our Requirements\"></a>\n"
+ " <a href=\"\" data-content=\"API's List\"></a>\n"
+ " </div>\n"
+ " <div id=\"user\" class=\"userDatas\" data-textarea=\"User\">\n"
+ " <a href=\"\" data-content=\"About User\"></a>\n"
+ " <a href=\"\" data-content=\"User Requests\"></a>\n"
+ " <a href=\"\" data-content=\"Enabled API's\"></a>\n"
+ " </div>\n"
+ " </aside>\n"
+ " <section id=\"userDetails\"></section>\n"
+ " <section class=\"content\"></section>\n"
+ " <footer></footer>\n"
+ " <!-- <script data-xd>mcgu/a-/AAuE7mA5Yb1qpx76aqsJ131_TaqMRgH1jd5nVUYrO9yDGQ=s96-c</script> -->\n"
+ " <!-- <script data-xd>mcgu/a-/AAuE7mA5Yb1qpx76aqsJ131_TaqMRgH1jd5nVUYrO9yDGQ=s96-c</script><script data-xd>mcgu/a-/AAuE7mA5Yb1qpx76aqsJ131_TaqMRgH1jd5nVUYrO9yDGQ=s96-c</script>\n"
+ " <script data-xd>mcgu/a-/AAuE7mA5Yb1qpx76aqsJ131_TaqMRgH1jd5nVUYrO9yDGQ=s96-c</script><script data-xd>mcgu/a-/AAuE7mA5Yb1qpx76aqsJ131_TaqMRgH1jd5nVUYrO9yDGQ=s96-c</script>\n"
+ " <script data-xd>mcgu/a-/AAuE7mA5Yb1qpx76aqsJ131_TaqMRgH1jd5nVUYrO9yDGQ=s96-c</script><script data-xd>mcgu/a-/AAuE7mA5Yb1qpx76aqsJ131_TaqMRgH1jd5nVUYrO9yDGQ=s96-c</script>\n"
+ " <script data-xd>mcgu/a-/AAuE7mA5Yb1qpx76aqsJ131_TaqMRgH1jd5nVUYrO9yDGQ=s96-c</script><script data-xd>mcgu/a-/AAuE7mA5Yb1qpx76aqsJ131_TaqMRgH1jd5nVUYrO9yDGQ=s96-c</script>\n\n"
+ " <script data-xd>mcgu/a-/AAuE7mA5Yb1qpx76aqsJ131_TaqMRgH1jd5nVUYrO9yDGQ=s96-c</script><script data-xd>mcgu/a-/AAuE7mA5Yb1qpx76aqsJ131_TaqMRgH1jd5nVUYrO9yDGQ=s96-c</script>\n\n\n"
+ " tdhuitjhuio5hrtjhtryhtujhtohju -->";
final String subst = "";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}