# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"\s*(<!--[\s\S]+?-->)"
test_str = (" <header class=\"afl\">\n"
" <div class=\"openClose\">\n"
" <div class=\"line line1\"></div>\n"
" <div class=\"line line2\"></div>\n"
" <div class=\"line line3\"></div>\n"
" </div>\n"
" <div class=\"ssLogo\">\n"
" <div class=\"c1\">\n"
" <div class=\"c2\">SS</div>\n"
" </div>\n"
" </div>\n"
" <!-- <script data-xd>mcgu/a-/AAuE7mA5Yb1qpx76aqsJ131_TaqMRgH1jd5nVUYrO9yDGQ=s96-c</script> -->\n"
" <!-- <script data-xd>mcgu/a-/AAuE7mA5Yb1qpx76aqsJ131_TaqMRgH1jd5nVUYrO9yDGQ=s96-c</script><script data-xd>mcgu/a-/AAuE7mA5Yb1qpx76aqsJ131_TaqMRgH1jd5nVUYrO9yDGQ=s96-c</script>\n"
" <script data-xd>mcgu/a-/AAuE7mA5Yb1qpx76aqsJ131_TaqMRgH1jd5nVUYrO9yDGQ=s96-c</script><script data-xd>mcgu/a-/AAuE7mA5Yb1qpx76aqsJ131_TaqMRgH1jd5nVUYrO9yDGQ=s96-c</script>\n"
" <script data-xd>mcgu/a-/AAuE7mA5Yb1qpx76aqsJ131_TaqMRgH1jd5nVUYrO9yDGQ=s96-c</script><script data-xd>mcgu/a-/AAuE7mA5Yb1qpx76aqsJ131_TaqMRgH1jd5nVUYrO9yDGQ=s96-c</script>\n"
" <script data-xd>mcgu/a-/AAuE7mA5Yb1qpx76aqsJ131_TaqMRgH1jd5nVUYrO9yDGQ=s96-c</script><script data-xd>mcgu/a-/AAuE7mA5Yb1qpx76aqsJ131_TaqMRgH1jd5nVUYrO9yDGQ=s96-c</script>\n\n"
" <script data-xd>mcgu/a-/AAuE7mA5Yb1qpx76aqsJ131_TaqMRgH1jd5nVUYrO9yDGQ=s96-c</script><script data-xd>mcgu/a-/AAuE7mA5Yb1qpx76aqsJ131_TaqMRgH1jd5nVUYrO9yDGQ=s96-c</script>\n\n\n"
" tdhuitjhuio5hrtjhtryhtujhtohju -->\n"
" <div class=\"ssText\">Social Services</div>\n"
" <div class=\"menu\">\n"
" <div class=\"userData\">\n"
" <div class=\"logo\">\n"
" <img class=\"userpicture\" src=\"https://lh3.googleusercontent.com/a-/AAuE7mA5Yb1qpx76aqsJ131_TaqMRgH1jd5nVUYrO9yDGQ=s96-c\" alt=\"MD Real\" />\n"
" </div>\n"
" </div>\n"
" </div>\n"
" </header>\n"
" <aside class=\"leftSidebar open\" id=\"menu\">\n"
" <div class=\"controls\">\n"
" <div class=\"openClose\">\n"
" <div class=\"line line1\"></div>\n"
" <div class=\"line line2\"></div>\n"
" <div class=\"line line3\"></div>\n"
" </div>\n"
" </div>\n"
" <!-- <script data-xd>mcgu/a-/AAuE7mA5Yb1qpx76aqsJ131_TaqMRgH1jd5nVUYrO9yDGQ=s96-c</script> -->\n"
" <!-- <script data-xd>mcgu/a-/AAuE7mA5Yb1qpx76aqsJ131_TaqMRgH1jd5nVUYrO9yDGQ=s96-c</script><script data-xd>mcgu/a-/AAuE7mA5Yb1qpx76aqsJ131_TaqMRgH1jd5nVUYrO9yDGQ=s96-c</script>\n"
" <script data-xd>mcgu/a-/AAuE7mA5Yb1qpx76aqsJ131_TaqMRgH1jd5nVUYrO9yDGQ=s96-c</script><script data-xd>mcgu/a-/AAuE7mA5Yb1qpx76aqsJ131_TaqMRgH1jd5nVUYrO9yDGQ=s96-c</script>\n"
" <script data-xd>mcgu/a-/AAuE7mA5Yb1qpx76aqsJ131_TaqMRgH1jd5nVUYrO9yDGQ=s96-c</script><script data-xd>mcgu/a-/AAuE7mA5Yb1qpx76aqsJ131_TaqMRgH1jd5nVUYrO9yDGQ=s96-c</script>\n"
" <script data-xd>mcgu/a-/AAuE7mA5Yb1qpx76aqsJ131_TaqMRgH1jd5nVUYrO9yDGQ=s96-c</script><script data-xd>mcgu/a-/AAuE7mA5Yb1qpx76aqsJ131_TaqMRgH1jd5nVUYrO9yDGQ=s96-c</script>\n\n"
" <script data-xd>mcgu/a-/AAuE7mA5Yb1qpx76aqsJ131_TaqMRgH1jd5nVUYrO9yDGQ=s96-c</script><script data-xd>mcgu/a-/AAuE7mA5Yb1qpx76aqsJ131_TaqMRgH1jd5nVUYrO9yDGQ=s96-c</script>\n\n\n"
" tdhuitjhuio5hrtjhtryhtujhtohju -->\n"
" <div id=\"system\" class=\"system\" data-textarea=\"Social Services\">\n"
" <a href=\"\" data-content=\"Our Requirements\"></a>\n"
" <a href=\"\" data-content=\"API's List\"></a>\n"
" </div>\n"
" <div id=\"user\" class=\"userDatas\" data-textarea=\"User\">\n"
" <a href=\"\" data-content=\"About User\"></a>\n"
" <a href=\"\" data-content=\"User Requests\"></a>\n"
" <a href=\"\" data-content=\"Enabled API's\"></a>\n"
" </div>\n"
" </aside>\n"
" <section id=\"userDetails\"></section>\n"
" <section class=\"content\"></section>\n"
" <footer></footer>\n"
" <!-- <script data-xd>mcgu/a-/AAuE7mA5Yb1qpx76aqsJ131_TaqMRgH1jd5nVUYrO9yDGQ=s96-c</script> -->\n"
" <!-- <script data-xd>mcgu/a-/AAuE7mA5Yb1qpx76aqsJ131_TaqMRgH1jd5nVUYrO9yDGQ=s96-c</script><script data-xd>mcgu/a-/AAuE7mA5Yb1qpx76aqsJ131_TaqMRgH1jd5nVUYrO9yDGQ=s96-c</script>\n"
" <script data-xd>mcgu/a-/AAuE7mA5Yb1qpx76aqsJ131_TaqMRgH1jd5nVUYrO9yDGQ=s96-c</script><script data-xd>mcgu/a-/AAuE7mA5Yb1qpx76aqsJ131_TaqMRgH1jd5nVUYrO9yDGQ=s96-c</script>\n"
" <script data-xd>mcgu/a-/AAuE7mA5Yb1qpx76aqsJ131_TaqMRgH1jd5nVUYrO9yDGQ=s96-c</script><script data-xd>mcgu/a-/AAuE7mA5Yb1qpx76aqsJ131_TaqMRgH1jd5nVUYrO9yDGQ=s96-c</script>\n"
" <script data-xd>mcgu/a-/AAuE7mA5Yb1qpx76aqsJ131_TaqMRgH1jd5nVUYrO9yDGQ=s96-c</script><script data-xd>mcgu/a-/AAuE7mA5Yb1qpx76aqsJ131_TaqMRgH1jd5nVUYrO9yDGQ=s96-c</script>\n\n"
" <script data-xd>mcgu/a-/AAuE7mA5Yb1qpx76aqsJ131_TaqMRgH1jd5nVUYrO9yDGQ=s96-c</script><script data-xd>mcgu/a-/AAuE7mA5Yb1qpx76aqsJ131_TaqMRgH1jd5nVUYrO9yDGQ=s96-c</script>\n\n\n"
" tdhuitjhuio5hrtjhtryhtujhtohju -->")
subst = ""
# You can manually specify the number of replacements by changing the 4th argument
result = re.sub(regex, subst, test_str, 0, re.MULTILINE)
if result:
print (result)
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.