#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "Z=(?<mfcdst>\w{6})\sP=(?<mfcprio>\d)\sU=(?<mfcsrc>\w{6}),\sWW=(?<mfcWW>\d),\sL=(?<mfcline>.*)\sB=(?<mfctrunk>.*)\sD=(?<mfcdur>\d\d:\d\d)\sE:(?<mfcend>\w*);$"
Local $sString = "ACC Stat;31.07.2018 23:54:39;;SVSA-ACC Z=999999 P=4 U=363898, WW=0, L=budvie0502 B=BUD Triangle D=00:00 E:Abweisend;"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")