re = /Z=(?<mfcdst>\w{6})\sP=(?<mfcprio>\d)\sU=(?<mfcsrc>\w{6}),\sWW=(?<mfcWW>\d),\sL=(?<mfcline>.*)\sB=(?<mfctrunk>.*)\sD=(?<mfcdur>\d\d:\d\d)\sE:(?<mfcend>\w*);$/
str = 'ACC Stat;31.07.2018 23:54:39;;SVSA-ACC Z=999999 P=4 U=363898, WW=0, L=budvie0502 B=BUD Triangle D=00:00 E:Abweisend;'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end