import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "Z=(?<mfcdst>\\w{6})\\sP=(?<mfcprio>\\d)\\sU=(?<mfcsrc>\\w{6}),\\sWW=(?<mfcWW>\\d),\\sL=(?<mfcline>.*)\\sB=(?<mfctrunk>.*)\\sD=(?<mfcdur>\\d\\d:\\d\\d)\\sE:(?<mfcend>\\w*);$";
final String string = "ACC Stat;31.07.2018 23:54:39;;SVSA-ACC Z=999999 P=4 U=363898, WW=0, L=budvie0502 B=BUD Triangle D=00:00 E:Abweisend;";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}