# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"Z=(?<mfcdst>\w{6})\sP=(?<mfcprio>\d)\sU=(?<mfcsrc>\w{6}),\sWW=(?<mfcWW>\d),\sL=(?<mfcline>.*)\sB=(?<mfctrunk>.*)\sD=(?<mfcdur>\d\d:\d\d)\sE:(?<mfcend>\w*);$"
test_str = "ACC Stat;31.07.2018 23:54:39;;SVSA-ACC Z=999999 P=4 U=363898, WW=0, L=budvie0502 B=BUD Triangle D=00:00 E:Abweisend;"
matches = re.finditer(regex, test_str)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.