using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?<=(index|Point|Frame)="")([^""]+)(?="".*?id=""([^""]+)"" node=""\2"")";
string substitution = @"\3";
string input = @"<movingPart index=""0>8|1|3"" referencePoint=""0>8|1|0|4"" referenceFrame=""0>"" scaleZ=""true""/>
bla
bla
<i3dMapping id=""KroneComprimaV180XC"" node=""0>"" />
<i3dMapping id=""novoGripPart2_fixPoint"" node=""0>8|1|0|4"" />
<i3dMapping id=""novoGrip_part2"" node=""0>8|1|3"" />";
RegexOptions options = RegexOptions.Singleline;
Regex regex = new Regex(pattern, options);
string result = regex.Replace(input, substitution);
}
}