$re = '/(?<=(index|Point|Frame)=")([^"]+)(?=".*?id="([^"]+)" node="\2")/s';
$str = '<movingPart index="0>8|1|3" referencePoint="0>8|1|0|4" referenceFrame="0>" scaleZ="true"/>
bla
bla
<i3dMapping id="KroneComprimaV180XC" node="0>" />
<i3dMapping id="novoGripPart2_fixPoint" node="0>8|1|0|4" />
<i3dMapping id="novoGrip_part2" node="0>8|1|3" />';
$subst = "\3";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;