use strict;
my $str = '<movingPart index="0>8|1|3" referencePoint="0>8|1|0|4" referenceFrame="0>" scaleZ="true"/>
bla
bla
<i3dMapping id="KroneComprimaV180XC" node="0>" />
<i3dMapping id="novoGripPart2_fixPoint" node="0>8|1|0|4" />
<i3dMapping id="novoGrip_part2" node="0>8|1|3" />';
my $regex = qr/(?<=(index|Point|Frame)=")([^"]+)(?=".*?id="([^"]+)" node="\2")/sp;
my $subst = '\\3';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";