#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)\$\$.*?\$\$"
Local $sString = "Il y a une equation juste ici $$x = \frac{-b \pm \sqrt{b^2-4ac}}{2a}$$ et elle vient de se terminer. Une autre là $$ \frac{-b \pm \sqrt{b^2-8b}} $$ jusqu'à là. Il y a une equation juste ici $$x = \frac{-b \pm \sqrt{b^2-4ac}}{2a}$$ et elle vient de se terminer. Une autre là $$ \frac{-b \pm \sqrt{b^2-8b}} $$ jusqu'à là $$ hey $$"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")