// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)\$\$.*?\$\$").unwrap();
let string = "Il y a une equation juste ici $$x = \\frac{-b \\pm \\sqrt{b^2-4ac}}{2a}$$ et elle vient de se terminer. Une autre là $$ \\frac{-b \\pm \\sqrt{b^2-8b}} $$ jusqu'à là. Il y a une equation juste ici $$x = \\frac{-b \\pm \\sqrt{b^2-4ac}}{2a}$$ et elle vient de se terminer. Une autre là $$ \\frac{-b \\pm \\sqrt{b^2-8b}} $$ jusqu'à là $$ hey $$";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}