$re = '/\$\$.*?\$\$/m';
$str = 'Il y a une equation juste ici $$x = \\frac{-b \\pm \\sqrt{b^2-4ac}}{2a}$$ et elle vient de se terminer. Une autre là $$ \\frac{-b \\pm \\sqrt{b^2-8b}} $$ jusqu\'à là. Il y a une equation juste ici $$x = \\frac{-b \\pm \\sqrt{b^2-4ac}}{2a}$$ et elle vient de se terminer. Une autre là $$ \\frac{-b \\pm \\sqrt{b^2-8b}} $$ jusqu\'à là $$ hey $$';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);