import Foundation
let pattern = #"\$\$.*?\$\$"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"Il y a une equation juste ici $$x = \frac{-b \pm \sqrt{b^2-4ac}}{2a}$$ et elle vient de se terminer. Une autre là $$ \frac{-b \pm \sqrt{b^2-8b}} $$ jusqu'à là. Il y a une equation juste ici $$x = \frac{-b \pm \sqrt{b^2-4ac}}{2a}$$ et elle vient de se terminer. Une autre là $$ \frac{-b \pm \sqrt{b^2-8b}} $$ jusqu'à là $$ hey $$"#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)