package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)>>(?<name>[A-Za-z]+)<<(?<price>\d+\.?\d+)!(?<quantity>\d+)`)
var str = `>>Sofa<<312.23!3
>>TV<<300!5
>Invalid<<!5`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}