$re = '/>>(?<name>[A-Za-z]+)<<(?<price>\d+\.?\d+)!(?<quantity>\d+)/m';
$str = '>>Sofa<<312.23!3
>>TV<<300!5
>Invalid<<!5';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);