import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^(?=\\d)(?:\\d+w\\h*)?(?:\\d+d\\h*)?(?:\\d+h\\h*)?(?:\\d+m)?$";
final String string = "1w 3d 5h 3m\n"
+ "32d 5h 3m\n"
+ "3pp 2h 35m\n"
+ "2d 5qq 3m\n"
+ "2d 35m\n"
+ "3h 1w\n";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}