import re
regex = re.compile(r"^(?=\d)(?:\d+w\h*)?(?:\d+d\h*)?(?:\d+h\h*)?(?:\d+m)?$", flags=re.MULTILINE)
test_str = ("1w 3d 5h 3m\n"
"32d 5h 3m\n"
"3pp 2h 35m\n"
"2d 5qq 3m\n"
"2d 35m\n"
"3h 1w\n")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")