$re = '/^(?=\d)(?:\d+w\h*)?(?:\d+d\h*)?(?:\d+h\h*)?(?:\d+m)?$/m';
$str = '1w 3d 5h 3m
32d 5h 3m
3pp 2h 35m
2d 5qq 3m
2d 35m
3h 1w
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);