using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^https?:\/\/www\.(?:[a-z0-9]-?)+[^-\.]\.[a-z]{2,15}(?:\.[a-z]{2})?$";
string input = @"######################## Match
http://www.example.co.sa
http://WWW.EXAMPLE.NET
http://www.google.com
http://www.some-site.engineering
https://www.google.com
http://www.efg-cba.asdfgh
######################## NO Match
www.google
www.google.com
mail.google.com
https://some-sub-domain.exam-ple.musem.uk
http://sub-domain.example-site.engineering
http://w-ww.mi-creativity.com
https://google.co.in
http://maps.google.com
http://google.com
://www.google
//www.google
:google.com
http://www..google.co.sa
http://www.google..co.uk
http://www.google.co..uk
htt:google.com
http:google.com
http:/google.com
http//www.google.com
http://www.go ogle.com
http://www.google.c om
http://www.-google.com
http://www.g--oogle.com
http://www.google-.com
http://www.-google.com
http://www.g--oogle.com
http://www.example.c
";
RegexOptions options = RegexOptions.Multiline | RegexOptions.IgnoreCase;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}