import Foundation
let pattern = #"^https?:\/\/www\.(?:[a-z0-9]-?)+[^-\.]\.[a-z]{2,15}(?:\.[a-z]{2})?$"#
let regex = try! NSRegularExpression(pattern: pattern, options: [.anchorsMatchLines, .caseInsensitive])
let testString = #########################"""
######################## Match
http://www.example.co.sa
http://WWW.EXAMPLE.NET
http://www.google.com
http://www.some-site.engineering
https://www.google.com
http://www.efg-cba.asdfgh
######################## NO Match
www.google
www.google.com
mail.google.com
https://some-sub-domain.exam-ple.musem.uk
http://sub-domain.example-site.engineering
http://w-ww.mi-creativity.com
https://google.co.in
http://maps.google.com
http://google.com
://www.google
//www.google
:google.com
http://www..google.co.sa
http://www.google..co.uk
http://www.google.co..uk
htt:google.com
http:google.com
http:/google.com
http//www.google.com
http://www.go ogle.com
http://www.google.c om
http://www.-google.com
http://www.g--oogle.com
http://www.google-.com
http://www.-google.com
http://www.g--oogle.com
http://www.example.c
"""#########################
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)