use strict;
my $str = '######################## Match
http://www.example.co.sa
http://WWW.EXAMPLE.NET
http://www.google.com
http://www.some-site.engineering
https://www.google.com
http://www.efg-cba.asdfgh
######################## NO Match
www.google
www.google.com
mail.google.com
https://some-sub-domain.exam-ple.musem.uk
http://sub-domain.example-site.engineering
http://w-ww.mi-creativity.com
https://google.co.in
http://maps.google.com
http://google.com
://www.google
//www.google
:google.com
http://www..google.co.sa
http://www.google..co.uk
http://www.google.co..uk
htt:google.com
http:google.com
http:/google.com
http//www.google.com
http://www.go ogle.com
http://www.google.c om
http://www.-google.com
http://www.g--oogle.com
http://www.google-.com
http://www.-google.com
http://www.g--oogle.com
http://www.example.c
';
my $regex = qr/^https?:\/\/www\.(?:[a-z0-9]-?)+[^-\.]\.[a-z]{2,15}(?:\.[a-z]{2})?$/mip;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}