package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?mi)^https?:\/\/www\.(?:[a-z0-9]-?)+[^-\.]\.[a-z]{2,15}(?:\.[a-z]{2})?$`)
var str = `######################## Match
http://www.example.co.sa
http://WWW.EXAMPLE.NET
http://www.google.com
http://www.some-site.engineering
https://www.google.com
http://www.efg-cba.asdfgh
######################## NO Match
www.google
www.google.com
mail.google.com
https://some-sub-domain.exam-ple.musem.uk
http://sub-domain.example-site.engineering
http://w-ww.mi-creativity.com
https://google.co.in
http://maps.google.com
http://google.com
://www.google
//www.google
:google.com
http://www..google.co.sa
http://www.google..co.uk
http://www.google.co..uk
htt:google.com
http:google.com
http:/google.com
http//www.google.com
http://www.go ogle.com
http://www.google.c om
http://www.-google.com
http://www.g--oogle.com
http://www.google-.com
http://www.-google.com
http://www.g--oogle.com
http://www.example.c
`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}